summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
committerMark Linimon <linimon@FreeBSD.org>2021-01-13 23:03:31 +0000
commitf86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2 (patch)
treedee6818341bc298df429631dc617ddfaf949f1e5
parent671839de5f6867f1f9e48aa527390d7495cbb750 (diff)
downloadfreebsd-ports-f86c964117b6a3ebf2cbf7bb69821dfb8a74f1c2.zip
Update GCC_DEFAULT from 9 to 10.
A few (mostly Fortran-based) ports need to be patched because GCC 10 is stricter. A handful of ports need to be restricted to GCC 9 because they fail with 10. 5 ports still fail with GCC 10. However, seeing as this work has been ongoing since 2020-05-24, it is simply time to make the commit and notify the affected maintainers. While here, pet portlint (Makevar order). PR: 246700 Submitted by: gerald Approved by: antoine (after many, many, -exp runs)
-rw-r--r--Mk/bsd.default-versions.mk2
-rw-r--r--cad/calculix-ccx/Makefile5
-rw-r--r--comms/wsjtx/Makefile7
-rw-r--r--databases/mariadb105-server/Makefile2
-rw-r--r--games/libretro-paralleln64/Makefile8
-rw-r--r--math/hs-penrose/Makefile6
-rw-r--r--math/mumps/Makefile5
-rw-r--r--math/octave-forge-optiminterp/Makefile10
-rw-r--r--math/scilab/Makefile7
-rw-r--r--net/iaxmodem/Makefile2
-rw-r--r--science/cp2k/Makefile4
-rw-r--r--science/elmerfem/Makefile6
-rw-r--r--science/getdp/Makefile7
-rw-r--r--science/libgridxc/Makefile6
-rw-r--r--science/pnetcdf/Makefile9
15 files changed, 80 insertions, 6 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index d55bb1a0c357..5641c8ea5ef4 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -53,7 +53,7 @@ GCC_DEFAULT?= 8
.elif ${ARCH} == "powerpc64le"
GCC_DEFAULT?= 10
.else
-GCC_DEFAULT?= 9
+GCC_DEFAULT?= 10
.endif
# Possible values: 7, 8, 9, agpl
GHOSTSCRIPT_DEFAULT?= agpl
diff --git a/cad/calculix-ccx/Makefile b/cad/calculix-ccx/Makefile
index df084ebf726b..3e74df4b9fca 100644
--- a/cad/calculix-ccx/Makefile
+++ b/cad/calculix-ccx/Makefile
@@ -55,6 +55,11 @@ CFLAGS+= -fpic
FFLAGS+= -fpic
.endif
+.if ${GCC_DEFAULT} >= 10
+# workaround for Missing actual argument for argument '_formal_15' at (1)
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
pre-build:
@${REINPLACE_CMD} -e 's+%%FC%%+${FC}+g ; s+%%CC%%+${CC}+g ; \
s+%%BLAS_LIBS%%+${BLASLIB}+ ; \
diff --git a/comms/wsjtx/Makefile b/comms/wsjtx/Makefile
index d3eb970450f4..c72109d673b7 100644
--- a/comms/wsjtx/Makefile
+++ b/comms/wsjtx/Makefile
@@ -36,6 +36,13 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
_PATCHES= wsjtx.patch hamlib.patch
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for More actual than formal arguments in procedure call at (1)
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
. for _patch in ${_PATCHES}
# Keep a copy of the blank patch for the post-build target below
diff --git a/databases/mariadb105-server/Makefile b/databases/mariadb105-server/Makefile
index 307d8af2460e..d11087f627dd 100644
--- a/databases/mariadb105-server/Makefile
+++ b/databases/mariadb105-server/Makefile
@@ -212,7 +212,7 @@ PLIST_SUB+= WSREP="@comment "
.endif
.if ${ARCH} == i386
-USE_GCC= yes
+USE_GCC= 9
CFLAGS+= -DHAVE_GCC_C11_ATOMICS -latomic -DUSE_NEW_READLINE_INTERFACE
CXXFLAGS+= -fpermissive
.endif
diff --git a/games/libretro-paralleln64/Makefile b/games/libretro-paralleln64/Makefile
index f85e0bacab34..dc08be2b9e20 100644
--- a/games/libretro-paralleln64/Makefile
+++ b/games/libretro-paralleln64/Makefile
@@ -32,8 +32,14 @@ GH_TAGNAME= 29e7f39
PLIST_FILES= lib/libretro/parallel_n64_libretro.so
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to link: ./mupen64plus-core/src/dd/dd_disk.o:(.bss+0xc): multiple definition of `CUR_BLOCK'
+.endif
+
do-install:
${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
${INSTALL_LIB} ${WRKSRC}/parallel_n64_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/hs-penrose/Makefile b/math/hs-penrose/Makefile
index 923541b3ff10..56d3e640e605 100644
--- a/math/hs-penrose/Makefile
+++ b/math/hs-penrose/Makefile
@@ -134,4 +134,10 @@ USE_CABAL= MonadRandom-0.5.1.2 \
x509-1.7.5_1 \
zlib-0.6.2.1_1
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: cabal: Missing dependency on a foreign library: Missing (or bad) C library: gfortran
+.endif
+
.include <bsd.port.mk>
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index fd4a1eea0a91..3ef794a77067 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -44,6 +44,11 @@ MAKE_JOBS_UNSAFE=yes
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../french/aster/bsd.aster.mk"
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch in argument 's' at (1); passed INTEGER(4) to LOGICAL(4)
+FCFLAGS+= -fallow-argument-mismatch
+.endif
+
.ifdef WITH_MPI
PKGNAMESUFFIX+= -mpich
.endif
diff --git a/math/octave-forge-optiminterp/Makefile b/math/octave-forge-optiminterp/Makefile
index c8d7e23abdac..b99e212edbc2 100644
--- a/math/octave-forge-optiminterp/Makefile
+++ b/math/octave-forge-optiminterp/Makefile
@@ -24,8 +24,16 @@ GNU_CONFIGURE= yes
MAKE_ENV+= MKOCTFILE_FORTRAN_90=yes MKOCTFILE=mkoctfile
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-2)
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 74bcac97861c..4f3b79aee85d 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -129,6 +129,13 @@ CONFIGURE_ARGS+= --without-openmp
CONFIGURE_ARGS+= --enable-debug
.endif
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch between actual argument at (1) and actual argument at (2) (rank-1 and scalar)
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${REINPLACE_CMD} 's,/usr/local,${LOCALBASE},' ${WRKSRC}/etc/librarypath.xml
@${REINPLACE_CMD} -e 's, gfortran, ${FC},' ${WRKSRC}/modules/dynamic_link/src/scripts/configure
diff --git a/net/iaxmodem/Makefile b/net/iaxmodem/Makefile
index a71a7ae4c1c2..159e50a11a12 100644
--- a/net/iaxmodem/Makefile
+++ b/net/iaxmodem/Makefile
@@ -31,7 +31,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
.if ${ARCH} == i386 && ${CHOSEN_COMPILER_TYPE} == clang
# gsm0610_rpe.c:81:10: error: invalid operand for instruction
-USE_GCC= yes
+USE_GCC= 9
.endif
post-patch:
diff --git a/science/cp2k/Makefile b/science/cp2k/Makefile
index abc060e1e2dc..7f403c847003 100644
--- a/science/cp2k/Makefile
+++ b/science/cp2k/Makefile
@@ -66,6 +66,10 @@ pre-configure:
fi
.endif
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: Element of assumed-shape or pointer array as actual argument at (1) cannot correspond to actual argument at (2)
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' 's|LIBS.*=.*|& ${LDFLAGS}|; s|^FCFLAGS.*=.*|& -I${LOCALBASE}/include|; s| -march=native||' ${WRKSRC}/arch/FreeBSD-*
diff --git a/science/elmerfem/Makefile b/science/elmerfem/Makefile
index 412309457bc4..95038bdbe6c9 100644
--- a/science/elmerfem/Makefile
+++ b/science/elmerfem/Makefile
@@ -74,6 +74,12 @@ FCFLAGS+= -fPIC
FFLAGS+= -fPIC
.endif
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch between actual argument at (1) and actual argument at (2) (REAL(8)/COMPLEX(8)).
+# in theory, this should set FCFLAGS, but the port does not conform
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${RM} -r ${WRKSRC}/elmergrid/src/metis-5.1.0
@${REINPLACE_CMD} -e 's,"metis.*/metis\.h",<metis.h>,' \
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 337df4153dc9..9ba6109b7f31 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -20,6 +20,13 @@ USES= fortran tar:tgz cmake
OPTIONS_DEFINE= DOCS EXAMPLES
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Rank mismatch in argument 'lines' at (1) (rank-1 and scalar)
+FFLAGS+= -fallow-argument-mismatch
+.endif
+
do-test:
cd ${WRKSRC}/demos && yes "" | ${STAGEDIR}${PREFIX}/bin/${PORTNAME} magnet.pro -solve MagSta_phi
diff --git a/science/libgridxc/Makefile b/science/libgridxc/Makefile
index 594fe5d60206..4cb5dc277961 100644
--- a/science/libgridxc/Makefile
+++ b/science/libgridxc/Makefile
@@ -37,6 +37,12 @@ LIBXC_MAKE_ENV= WITH_LIBXC=1
LIBXC_LIB_DEPENDS= libxc.so:science/libxc
LIBXC_BROKEN= Fails to build with libxc-5.0.0: https://bugs.launchpad.net/libgridxc/+bug/1899578
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(8)/INTEGER(4)).
+.endif
+
post-patch:
@${MKDIR} ${BUILD_WRKSRC}
@${CAT} ${WRKSRC}/../extra/fortran.mk \
diff --git a/science/pnetcdf/Makefile b/science/pnetcdf/Makefile
index 8f486de2a70e..4368367a3156 100644
--- a/science/pnetcdf/Makefile
+++ b/science/pnetcdf/Makefile
@@ -25,8 +25,8 @@ CFLAGS+= -fPIC
CONFIGURE_ARGS= ac_cv_fc_compiler_nag=no
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-USE_PERL5= build
USES= fortran gmake pathfix perl5 tar:bzip2
+USE_PERL5= build
PORTDOCS= COPYRIGHT INSTALL README
@@ -37,6 +37,13 @@ OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi
OPENMPI3_CONFIGURE_ON= --with-mpi=${LOCALBASE}/mpi/openmpi3
OPENMPI3_LIB_DEPENDS= libmpi.so:net/openmpi3
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+# workaround for Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(8)/CHARACTER(*)).
+FCFLAGS+= -fallow-argument-mismatch
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/$$(INSTALL.*$$(PREFIX)/ s|$$(PREFIX)|$$(DESTDIR)&|' ${WRKSRC}/Makefile.in