summaryrefslogtreecommitdiff
path: root/science/libgridxc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/libgridxc/Makefile')
-rw-r--r--science/libgridxc/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/science/libgridxc/Makefile b/science/libgridxc/Makefile
index 594fe5d60206..4cb5dc277961 100644
--- a/science/libgridxc/Makefile
+++ b/science/libgridxc/Makefile
@@ -37,6 +37,12 @@ LIBXC_MAKE_ENV= WITH_LIBXC=1
LIBXC_LIB_DEPENDS= libxc.so:science/libxc
LIBXC_BROKEN= Fails to build with libxc-5.0.0: https://bugs.launchpad.net/libgridxc/+bug/1899578
+.include <bsd.port.pre.mk>
+
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(8)/INTEGER(4)).
+.endif
+
post-patch:
@${MKDIR} ${BUILD_WRKSRC}
@${CAT} ${WRKSRC}/../extra/fortran.mk \