summaryrefslogtreecommitdiff
path: root/science/cp2k/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/cp2k/Makefile')
-rw-r--r--science/cp2k/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/science/cp2k/Makefile b/science/cp2k/Makefile
index abc060e1e2dc..7f403c847003 100644
--- a/science/cp2k/Makefile
+++ b/science/cp2k/Makefile
@@ -66,6 +66,10 @@ pre-configure:
fi
.endif
+.if ${GCC_DEFAULT} >= 10
+BROKEN= fails to build with GCC 10: Element of assumed-shape or pointer array as actual argument at (1) cannot correspond to actual argument at (2)
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' 's|LIBS.*=.*|& ${LDFLAGS}|; s|^FCFLAGS.*=.*|& -I${LOCALBASE}/include|; s| -march=native||' ${WRKSRC}/arch/FreeBSD-*