summaryrefslogtreecommitdiff
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
index ada49f185..7d4ec7aa5 100644
--- a/src/protocols/CMakeLists.txt
+++ b/src/protocols/CMakeLists.txt
@@ -14,4 +14,11 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-ADD_SUBDIRECTORY( irc )
+SET(LIB_PROTOCOLS_SRC protocols.c protocols.h)
+
+INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR})
+ADD_LIBRARY(weechat_protocols STATIC ${LIB_PROTOCOLS_SRC})
+
+IF(NOT DISABLE_IRC)
+ ADD_SUBDIRECTORY( irc )
+ENDIF(NOT DISABLE_IRC)