summaryrefslogtreecommitdiff
path: root/src/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2007-09-21 16:53:18 +0200
committerSebastien Helleu <flashcode@flashtux.org>2007-09-21 16:53:18 +0200
commit6ed8f34fdb9bf4184142211b77e556387514b952 (patch)
tree7a0720ccbff9369fe240580498e3c788a62bf538 /src/protocols/CMakeLists.txt
parent16f2d59a6b8d586ceaffaef808d02ebba0b3dd73 (diff)
downloadweechat-6ed8f34fdb9bf4184142211b77e556387514b952.zip
Added build of protocols lib, IRC protocol is now optional for build
Build of src/protocols/lib_weechat_protocols.a was added. IRC protocol is now optional in configure and cmake builds.
Diffstat (limited to 'src/protocols/CMakeLists.txt')
-rw-r--r--src/protocols/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/protocols/CMakeLists.txt b/src/protocols/CMakeLists.txt
index ada49f185..7d4ec7aa5 100644
--- a/src/protocols/CMakeLists.txt
+++ b/src/protocols/CMakeLists.txt
@@ -14,4 +14,11 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-ADD_SUBDIRECTORY( irc )
+SET(LIB_PROTOCOLS_SRC protocols.c protocols.h)
+
+INCLUDE_DIRECTORIES(${CMAKE_BINARY_DIR})
+ADD_LIBRARY(weechat_protocols STATIC ${LIB_PROTOCOLS_SRC})
+
+IF(NOT DISABLE_IRC)
+ ADD_SUBDIRECTORY( irc )
+ENDIF(NOT DISABLE_IRC)