summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@0x90.dk>2014-07-02 23:17:36 +0200
committerAlexander Færøy <ahf@0x90.dk>2014-07-02 23:17:36 +0200
commitfd3676e40783e7a24ace7cb652dea72411737fdd (patch)
tree9b87475b59130900da5c15cc92040b7f94191b1a /configure.ac
parent0a221742649cf39db96da69dead0292fd38c7b66 (diff)
parent96a292d40e7f6fe505c4a0f686d35132ffac8208 (diff)
downloadirssi-fd3676e40783e7a24ace7cb652dea72411737fdd.zip
Merge pull request #48 from ailin-nemui/256-colour-history
256 colour support for Irssi
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d409be36..04c50b4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,15 @@ AC_ARG_ENABLE(dane,
fi,
want_dane=no)
+AC_ARG_ENABLE(true-color,
+[ --enable-true-color Build with true color support in terminal],
+ if test x$enableval = xno ; then
+ want_truecolor=no
+ else
+ want_truecolor=yes
+ fi,
+ want_truecolor=no)
+
dnl **
dnl ** SSL Library checks (OpenSSL)
dnl **
@@ -643,6 +652,12 @@ if test "x$want_dane" = "xyes"; then
fi
fi
+if test "x$want_truecolor" = "xyes" -a "x$want_termcap" != "xyes" -a "x$want_terminfo" = "xyes" ; then
+ AC_DEFINE([TERM_TRUECOLOR], [], [true color support in terminal])
+else
+ want_truecolor=no
+fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile
@@ -761,6 +776,7 @@ echo "Building with SSL support ........ : $have_openssl"
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with garbage collector .. : $have_gc"
echo "Building with DANE support ....... : $have_dane"
+echo "Building with true color support.. : $want_truecolor"
echo
echo "If there are any problems, read the INSTALL file."