summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAilin Nemui <ailin@esf51.localdomain>2014-01-09 15:20:29 +0100
committerAilin Nemui <ailin@esf51.localdomain>2014-06-30 02:41:34 +0200
commit96a292d40e7f6fe505c4a0f686d35132ffac8208 (patch)
tree6f101c12381cbf47b19ce85499a81435a1d9f4f6 /configure.ac
parent2d4edc51877719c49d712271967313310f4796fb (diff)
downloadirssi-96a292d40e7f6fe505c4a0f686d35132ffac8208.zip
Finish 256 colour support for Irssi
256 colour patch is cleaned up and the remaining cases are made work, this includes especially Theme support, which was not implemented before. Changes not related to colours were reverted again, making a review of the two patches against master easier to follow. As a byproduct of the Hex-colour code parser, the 24bit colours are also implemented. Actually using them in the terminal is guarded by a compile time switch (as well as a run time switch), as it breaks the existing colour protocol and requires additional storage. To make a seamless usage, down-conversion is provided for 8 and 16 colours. Diverging from Tom's approach, the colour protocol is reverted back to the original one. Unfortunately, the changes required in the Theme engine will break the API. For more details, please refer to the patch documentation at either http://irssi-docs.wikispaces.com/Notes-256-Colour or https://github.com/shabble/irssi-docs/wiki/Notes-256-Colour
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d409be36..04c50b4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,6 +166,15 @@ AC_ARG_ENABLE(dane,
fi,
want_dane=no)
+AC_ARG_ENABLE(true-color,
+[ --enable-true-color Build with true color support in terminal],
+ if test x$enableval = xno ; then
+ want_truecolor=no
+ else
+ want_truecolor=yes
+ fi,
+ want_truecolor=no)
+
dnl **
dnl ** SSL Library checks (OpenSSL)
dnl **
@@ -643,6 +652,12 @@ if test "x$want_dane" = "xyes"; then
fi
fi
+if test "x$want_truecolor" = "xyes" -a "x$want_termcap" != "xyes" -a "x$want_terminfo" = "xyes" ; then
+ AC_DEFINE([TERM_TRUECOLOR], [], [true color support in terminal])
+else
+ want_truecolor=no
+fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile
@@ -761,6 +776,7 @@ echo "Building with SSL support ........ : $have_openssl"
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with garbage collector .. : $have_gc"
echo "Building with DANE support ....... : $have_dane"
+echo "Building with true color support.. : $want_truecolor"
echo
echo "If there are any problems, read the INSTALL file."