summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFrans Pop <elendil@planet.nl>2009-08-16 07:18:59 +0000
committerFrans Pop <elendil@planet.nl>2009-08-16 07:18:59 +0000
commit09980ee088c0d734767fc51563686e28c1af58a5 (patch)
tree87109b9451a79bf187fdc800bb02618db121477d /debian
parent160fe208b7f7f76fe47c47faf1d0a1bda943d9cf (diff)
downloadinstallation-guide-09980ee088c0d734767fc51563686e28c1af58a5.zip
Move most build dependencies to Build-Depends-Indep
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control15
-rwxr-xr-xdebian/genbuilddeps4
3 files changed, 13 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index f9898e8d4..678181258 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -45,7 +45,10 @@ installation-guide (2009xxxx) UNRELEASED; urgency=low
network configuration. Thanks to Anthony L. Awtrey <tony@awtrey.com>
for the patch.
- -- Frans Pop <fjp@debian.org> Sun, 02 Aug 2009 10:53:20 +0200
+ [ Frans Pop ]
+ * Move most build dependencies to Build-Depends-Indep.
+
+ -- Frans Pop <fjp@debian.org> Sun, 16 Aug 2009 09:16:55 +0200
installation-guide (20090427) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 08e82894e..b328d3ce5 100644
--- a/debian/control
+++ b/debian/control
@@ -3,16 +3,15 @@ Section: doc
Priority: optional
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Uploaders: Joey Hess <joeyh@debian.org>, Frans Pop <fjp@debian.org>
-Standards-Version: 3.7.3
+Standards-Version: 3.8.2
Vcs-Svn: svn://svn.debian.org/d-i/trunk/manual
-Build-Depends: debhelper (>= 4), docbook, docbook-xml, docbook-xsl, xsltproc, gawk, libhtml-parser-perl, w3m, poxml, jadetex, openjade | openjade1.3, docbook-dsssl, ghostscript, texlive-lang-cyrillic, texlive-lang-czechslovak, texlive-lang-finnish, texlive-lang-french, texlive-lang-german, texlive-lang-greek, texlive-lang-italian, texlive-lang-other, texlive-lang-portuguese, texlive-lang-spanish, texlive-lang-swedish, texlive-lang-vietnamese, ko.tex-base, cm-super
-# This comment can also be used to generate a Build-Depends line, by
-# running the debian/genbuilddeps program. So put each build dep on its
-# own line, prefixed by " - " and to comment out a build dep, start the
-# line with two hashes. And don't edit the Build-Depends line above by hand.
+Build-Depends: debhelper (>= 4)
+Build-Depends-Indep: docbook, docbook-xml, docbook-xsl, xsltproc, gawk, libhtml-parser-perl, w3m, poxml, jadetex, openjade | openjade1.3, docbook-dsssl, ghostscript, texlive-lang-cyrillic, texlive-lang-czechslovak, texlive-lang-finnish, texlive-lang-french, texlive-lang-german, texlive-lang-greek, texlive-lang-italian, texlive-lang-other, texlive-lang-portuguese, texlive-lang-spanish, texlive-lang-swedish, texlive-lang-vietnamese, ko.tex-base, cm-super
+# This comment can also be used to generate a Build-Depends-Indep line, by
+# running the debian/genbuilddeps program. So put each build dep on its own
+# line, prefixed by " - " and to comment out a build dep, start the line
+# with two hashes. And don't edit the Build-Depends-Indep line above by hand.
#
-# - debhelper (>= 4)
-# Of course.
# - docbook
# - docbook-xml
# - docbook-xsl
diff --git a/debian/genbuilddeps b/debian/genbuilddeps
index ca94a4f06..1a35afec0 100755
--- a/debian/genbuilddeps
+++ b/debian/genbuilddeps
@@ -1,6 +1,6 @@
#!/usr/bin/perl
# Generate build deps line from comments in the control file and replace
-# the current build deps line in the control file with it.
+# the current Build-Depends-Indep line in the control file with it.
my $control;
if (-e "debian/control") {
@@ -28,7 +28,7 @@ close IN;
my $builddeps=join(", ", @builddeps);
open (OUT, ">$control.tmp") || die "write $control.tmp: $!";
foreach (@lines) {
- s/^(Build-Depends:\s+)(.*)/$1$builddeps/;
+ s/^(Build-Depends-Indep:\s+)(.*)/$1$builddeps/;
print OUT || die "print: $!";
}
close OUT || die "close: $!";