summaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-13 12:20:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-13 12:20:56 +0000
commitb26c12b1e1bf776ecffdadffd6a81b412ed5a1e2 (patch)
tree6539231294629cea9082eaccdf469ff0ba8cb08c /security
parenta72d9806fb2d097b01d52f44d18a723f7b7e8eb8 (diff)
downloadfreebsd-ports-b26c12b1e1bf776ecffdadffd6a81b412ed5a1e2.zip
- Update to 4.2.0
- Fix LICENSE - Add LICENSE_FILE - Add testing support PR: 233190 Submitted by: takefu@airport.fm
Diffstat (limited to 'security')
-rw-r--r--security/wolfssl/Makefile24
-rw-r--r--security/wolfssl/distinfo6
-rw-r--r--security/wolfssl/pkg-plist10
3 files changed, 24 insertions, 16 deletions
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
index cfa243826744..062d74b65029 100644
--- a/security/wolfssl/Makefile
+++ b/security/wolfssl/Makefile
@@ -1,32 +1,34 @@
# $FreeBSD$
PORTNAME= wolfssl
-PORTVERSION= 3.13.0
+PORTVERSION= 4.2.0
CATEGORIES= security devel
MASTER_SITES= https://www.wolfssl.com/
MAINTAINER= ports@FreeBSD.org
COMMENT= Embedded SSL C-Library
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_mips= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
-BROKEN_mips64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
-
-BUILD_DEPENDS= bash:shells/bash
+BROKEN_mips= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
+BROKEN_mips64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
USES= libtool zip
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-CONFIGURE_SHELL=bash
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-shared --enable-static \
--enable-dtls --enable-opensslextra --enable-ipv6 \
--enable-dsa --enable-dh --enable-ecc --enable-sni \
- --enable-ripemd --enable-sha512 --enable-opensslcoexist
-
-USE_LDCONFIG= yes
+ --enable-ripemd --enable-sha512 --enable-opensslcoexist\
+ --enable-tls13 --enable-tls13-draft18\
+ --enable-tls13-draft22 --enable-tls13-draft23\
+ --enable-tls13-draft26 --enable-tls13-draft28\
+ --enable-ssh --enable-keygen
+TEST_TARGET= check
PORTDOCS= *
-
OPTIONS_DEFINE= DOCS
post-configure:
diff --git a/security/wolfssl/distinfo b/security/wolfssl/distinfo
index cfc281295e83..5f927cb5e823 100644
--- a/security/wolfssl/distinfo
+++ b/security/wolfssl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514202234
-SHA256 (wolfssl-3.13.0.zip) = 196a3256a9044ecb89504ce77850342c82e676e7f2cad77f5584be3516b6060e
-SIZE (wolfssl-3.13.0.zip) = 3969070
+TIMESTAMP = 1575422350
+SHA256 (wolfssl-4.2.0.zip) = 7aa4c8b9ac7eed76f0275abb13b4bd59a2e749211242cc6e364c3cdc9f3d959d
+SIZE (wolfssl-4.2.0.zip) = 7181171
diff --git a/security/wolfssl/pkg-plist b/security/wolfssl/pkg-plist
index b38f7f0be492..3fd054cf3703 100644
--- a/security/wolfssl/pkg-plist
+++ b/security/wolfssl/pkg-plist
@@ -99,6 +99,7 @@ include/wolfssl/openssl/aes.h
include/wolfssl/openssl/asn1.h
include/wolfssl/openssl/bio.h
include/wolfssl/openssl/bn.h
+include/wolfssl/openssl/buffer.h
include/wolfssl/openssl/conf.h
include/wolfssl/openssl/crypto.h
include/wolfssl/openssl/des.h
@@ -116,13 +117,16 @@ include/wolfssl/openssl/hmac.h
include/wolfssl/openssl/lhash.h
include/wolfssl/openssl/md4.h
include/wolfssl/openssl/md5.h
+include/wolfssl/openssl/objects.h
include/wolfssl/openssl/ocsp.h
include/wolfssl/openssl/opensslconf.h
include/wolfssl/openssl/opensslv.h
include/wolfssl/openssl/ossl_typ.h
include/wolfssl/openssl/pem.h
+include/wolfssl/openssl/pkcs7.h
include/wolfssl/openssl/pkcs12.h
include/wolfssl/openssl/rand.h
+include/wolfssl/openssl/rc4.h
include/wolfssl/openssl/ripemd.h
include/wolfssl/openssl/rsa.h
include/wolfssl/openssl/sha.h
@@ -130,6 +134,7 @@ include/wolfssl/openssl/ssl.h
include/wolfssl/openssl/ssl23.h
include/wolfssl/openssl/stack.h
include/wolfssl/openssl/ui.h
+include/wolfssl/openssl/x509_vfy.h
include/wolfssl/openssl/x509.h
include/wolfssl/openssl/x509v3.h
include/wolfssl/options.h
@@ -152,6 +157,7 @@ include/wolfssl/wolfcrypt/cmac.h
include/wolfssl/wolfcrypt/coding.h
include/wolfssl/wolfcrypt/compress.h
include/wolfssl/wolfcrypt/cpuid.h
+include/wolfssl/wolfcrypt/cryptocb.h
include/wolfssl/wolfcrypt/curve25519.h
include/wolfssl/wolfcrypt/des3.h
include/wolfssl/wolfcrypt/dh.h
@@ -201,6 +207,6 @@ include/wolfssl/wolfcrypt/wolfmath.h
include/wolfssl/wolfio.h
lib/libwolfssl.a
lib/libwolfssl.so
-lib/libwolfssl.so.15
-lib/libwolfssl.so.15.0.0
+lib/libwolfssl.so.23
+lib/libwolfssl.so.23.0.0
libdata/pkgconfig/wolfssl.pc