summaryrefslogtreecommitdiff
path: root/security/wolfssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/wolfssl/Makefile')
-rw-r--r--security/wolfssl/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
index cfa243826744..062d74b65029 100644
--- a/security/wolfssl/Makefile
+++ b/security/wolfssl/Makefile
@@ -1,32 +1,34 @@
# $FreeBSD$
PORTNAME= wolfssl
-PORTVERSION= 3.13.0
+PORTVERSION= 4.2.0
CATEGORIES= security devel
MASTER_SITES= https://www.wolfssl.com/
MAINTAINER= ports@FreeBSD.org
COMMENT= Embedded SSL C-Library
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_mips= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
-BROKEN_mips64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
-
-BUILD_DEPENDS= bash:shells/bash
+BROKEN_mips= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
+BROKEN_mips64= fails to package: pkg-static: Unable to access file libwolfssl.so.3: No such file or directory
USES= libtool zip
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
-CONFIGURE_SHELL=bash
CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-shared --enable-static \
--enable-dtls --enable-opensslextra --enable-ipv6 \
--enable-dsa --enable-dh --enable-ecc --enable-sni \
- --enable-ripemd --enable-sha512 --enable-opensslcoexist
-
-USE_LDCONFIG= yes
+ --enable-ripemd --enable-sha512 --enable-opensslcoexist\
+ --enable-tls13 --enable-tls13-draft18\
+ --enable-tls13-draft22 --enable-tls13-draft23\
+ --enable-tls13-draft26 --enable-tls13-draft28\
+ --enable-ssh --enable-keygen
+TEST_TARGET= check
PORTDOCS= *
-
OPTIONS_DEFINE= DOCS
post-configure: