summaryrefslogtreecommitdiff
path: root/lang/php73
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2020-07-13 13:32:27 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2020-07-13 13:32:27 +0000
commit6d23d80a69ba2c8ff3b90f995c79afac90f620cb (patch)
tree9444e62c020cfa80faa4f50dc97014961026048b /lang/php73
parentc6062b5c4768af566f9600630df198efce523c05 (diff)
downloadfreebsd-ports-6d23d80a69ba2c8ff3b90f995c79afac90f620cb.zip
mail/php7[2-4]-imap: change client from cclient to panda-cclient
There are some reports about PHP crashes, when using php-imap (especially with OpenSSL and TSL 1.3). All this problems went away, when using the panda-cclient instead of the old cclient. Therefore we make the panda-cclient the new default, but still allow cclient in order to allow backwards compatibility. Special thanks to bofh for figuring out the complex details and the solution! Special thanks to Jason for being patience and helpful about so many months! Reported by: Jason de Cordoba <jason@aventia.pw> Reviewed by: bofh Sponsored by: Bounce Experts
Diffstat (limited to 'lang/php73')
-rw-r--r--lang/php73/Makefile.ext5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/php73/Makefile.ext b/lang/php73/Makefile.ext
index 7f46e1e6667b..7cf4a654bfe9 100644
--- a/lang/php73/Makefile.ext
+++ b/lang/php73/Makefile.ext
@@ -146,7 +146,10 @@ USES+= iconv:translit
.if ${PHP_MODNAME} == "imap"
PHP_MOD_PRIO= 30
-OPTIONS_DEFINE= PANDA
+OPTIONS_RADIO= CLIENT
+OPTIONS_RADIO_CLIENT= CCLIENT PANDA
+OPTIONS_DEFAULT=PANDA
+CCLIENT_DESC= Uses the original but unmaintained cclient
PANDA_DESC= Uses the forked panda-cclient instead of the original cclient
CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \