diff options
author | Torsten Zuehlsdorff <tz@FreeBSD.org> | 2020-07-13 13:32:27 +0000 |
---|---|---|
committer | Torsten Zuehlsdorff <tz@FreeBSD.org> | 2020-07-13 13:32:27 +0000 |
commit | 6d23d80a69ba2c8ff3b90f995c79afac90f620cb (patch) | |
tree | 9444e62c020cfa80faa4f50dc97014961026048b | |
parent | c6062b5c4768af566f9600630df198efce523c05 (diff) | |
download | freebsd-ports-6d23d80a69ba2c8ff3b90f995c79afac90f620cb.zip |
mail/php7[2-4]-imap: change client from cclient to panda-cclient
There are some reports about PHP crashes, when using php-imap
(especially with OpenSSL and TSL 1.3). All this problems went away,
when using the panda-cclient instead of the old cclient.
Therefore we make the panda-cclient the new default,
but still allow cclient in order to allow backwards compatibility.
Special thanks to bofh for figuring out the complex details and
the solution!
Special thanks to Jason for being patience and
helpful about so many months!
Reported by: Jason de Cordoba <jason@aventia.pw>
Reviewed by: bofh
Sponsored by: Bounce Experts
-rw-r--r-- | UPDATING | 12 | ||||
-rw-r--r-- | lang/php72/Makefile.ext | 5 | ||||
-rw-r--r-- | lang/php73/Makefile.ext | 5 | ||||
-rw-r--r-- | lang/php74/Makefile.ext | 5 | ||||
-rw-r--r-- | mail/php72-imap/Makefile | 1 | ||||
-rw-r--r-- | mail/php73-imap/Makefile | 1 | ||||
-rw-r--r-- | mail/php74-imap/Makefile | 1 |
7 files changed, 27 insertions, 3 deletions
@@ -6,6 +6,18 @@ You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. +20200713: + AFFECTS: users of mail/php7[2-4]-imap + AUTHOR: tz@FreeBSD.org + + The imap module of PHP was compiled against cclient till now. But this lib is + unmaintained for over 7 years. When combined with modern OpenSSL there are + various crashes reported. + + Switching to the fork panda-cclient fixes these issues. Therefore we make the + usage of Panda cclient the new default. If you want to use the old cclient, + you need to enable it now! + 20200616: AFFECTS: users of www/baikal AUTHOR: gahr@FreeBSD.org diff --git a/lang/php72/Makefile.ext b/lang/php72/Makefile.ext index a95a41bac1d1..7b189ee8bdb1 100644 --- a/lang/php72/Makefile.ext +++ b/lang/php72/Makefile.ext @@ -146,7 +146,10 @@ USES+= iconv:translit .if ${PHP_MODNAME} == "imap" PHP_MOD_PRIO= 30 -OPTIONS_DEFINE= PANDA +OPTIONS_RADIO= CLIENT +OPTIONS_RADIO_CLIENT= CCLIENT PANDA +OPTIONS_DEFAULT=PANDA +CCLIENT_DESC= Uses the original but unmaintained cclient PANDA_DESC= Uses the forked panda-cclient instead of the original cclient CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \ diff --git a/lang/php73/Makefile.ext b/lang/php73/Makefile.ext index 7f46e1e6667b..7cf4a654bfe9 100644 --- a/lang/php73/Makefile.ext +++ b/lang/php73/Makefile.ext @@ -146,7 +146,10 @@ USES+= iconv:translit .if ${PHP_MODNAME} == "imap" PHP_MOD_PRIO= 30 -OPTIONS_DEFINE= PANDA +OPTIONS_RADIO= CLIENT +OPTIONS_RADIO_CLIENT= CCLIENT PANDA +OPTIONS_DEFAULT=PANDA +CCLIENT_DESC= Uses the original but unmaintained cclient PANDA_DESC= Uses the forked panda-cclient instead of the original cclient CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \ diff --git a/lang/php74/Makefile.ext b/lang/php74/Makefile.ext index 01f55e8392d3..49be3b8fab1b 100644 --- a/lang/php74/Makefile.ext +++ b/lang/php74/Makefile.ext @@ -144,7 +144,10 @@ USES+= iconv:translit .if ${PHP_MODNAME} == "imap" PHP_MOD_PRIO= 30 -OPTIONS_DEFINE= PANDA +OPTIONS_RADIO= CLIENT +OPTIONS_RADIO_CLIENT= CCLIENT PANDA +OPTIONS_DEFAULT=PANDA +CCLIENT_DESC= Uses the original but unmaintained cclient PANDA_DESC= Uses the forked panda-cclient instead of the original cclient CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \ diff --git a/mail/php72-imap/Makefile b/mail/php72-imap/Makefile index 0d9e7835f449..35269b7528e6 100644 --- a/mail/php72-imap/Makefile +++ b/mail/php72-imap/Makefile @@ -1,5 +1,6 @@ # $FreeBSD$ +PORTREVISION= 1 CATEGORIES= mail MASTERDIR= ${.CURDIR}/../../lang/php72 diff --git a/mail/php73-imap/Makefile b/mail/php73-imap/Makefile index adfe95ecf964..acc8bcdae52b 100644 --- a/mail/php73-imap/Makefile +++ b/mail/php73-imap/Makefile @@ -1,5 +1,6 @@ # $FreeBSD$ +PORTREVISION= 1 CATEGORIES= mail MASTERDIR= ${.CURDIR}/../../lang/php73 diff --git a/mail/php74-imap/Makefile b/mail/php74-imap/Makefile index 8beb5d7a669a..df76c7777fc9 100644 --- a/mail/php74-imap/Makefile +++ b/mail/php74-imap/Makefile @@ -1,5 +1,6 @@ # $FreeBSD$ +PORTREVISION= 1 CATEGORIES= mail MASTERDIR= ${.CURDIR}/../../lang/php74 |