summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTobias Brox <tobias@redpill-linpro.com>2021-12-30 03:52:25 +0100
committerTobias Brox <tobias@redpill-linpro.com>2021-12-30 03:52:25 +0100
commit46f66948473dc0b0ef98525e03bdf73d43992b1d (patch)
tree74e3b2302579d0e62b39b9ff53f4785ff989660d /setup.py
parent64892380606729b022daeadd5d7b82b4795964a3 (diff)
downloadcalendar-cli-46f66948473dc0b0ef98525e03bdf73d43992b1d.zip
working on the new kal interface
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0d097c1..dbd6bd6 100644
--- a/setup.py
+++ b/setup.py
@@ -29,12 +29,19 @@ setup(
"Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
],
scripts=['calendar-cli.py', 'calendar-cli'],
+ py_modules=['cal'],
install_requires=[
'icalendar',
'caldav>=0.8.1',
'pytz', ## pytz is supposed to be obsoleted, but see https://github.com/collective/icalendar/issues/333
'tzlocal',
+ 'Click',
'six'
],
+ entry_points={
+ 'console_scripts': [
+ 'kal = cal:cli',
+ ],
+ },
**metadata
)