summaryrefslogtreecommitdiff
path: root/systest/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2015-10-07 10:21:47 -0700
committerAlex Crichton <alex@alexcrichton.com>2015-10-07 10:21:47 -0700
commit251ec8bdd0f8010ffb1f82853652d6566e1e6a13 (patch)
treeda235d261e73fe3c42698bfe4a38e50db148227e /systest/Cargo.toml
parentd5b69eb0db8f1054246c273a3d49c6209dc90366 (diff)
downloadssh2-rs-251ec8bdd0f8010ffb1f82853652d6566e1e6a13.zip
Add automated testing of FFI bindings
Diffstat (limited to 'systest/Cargo.toml')
-rw-r--r--systest/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/systest/Cargo.toml b/systest/Cargo.toml
new file mode 100644
index 0000000..af981da
--- /dev/null
+++ b/systest/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "systest"
+version = "0.1.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+build = "build.rs"
+
+[dependencies]
+libssh2-sys = { path = "../libssh2-sys" }
+libc = "0.1"
+
+[build-dependencies]
+ctest = { git = "https://github.com/alexcrichton/ctest" }