summaryrefslogtreecommitdiff
path: root/libssh2-sys/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2016-03-22 09:52:37 -0700
committerAlex Crichton <alex@alexcrichton.com>2016-03-22 09:52:37 -0700
commit593df2538bcd1383d334c65f09b1ecd78a9f0015 (patch)
treec2e04a18c7b8e7976e21b92d00a66650c6a167a2 /libssh2-sys/Cargo.toml
parent9eb9a5b85c359e1ee8aa8016eecb516039bf4069 (diff)
downloadssh2-rs-593df2538bcd1383d334c65f09b1ecd78a9f0015.zip
Add cfg(unix) dep for openssl
Diffstat (limited to 'libssh2-sys/Cargo.toml')
-rw-r--r--libssh2-sys/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/libssh2-sys/Cargo.toml b/libssh2-sys/Cargo.toml
index 0f1a277..0d8043d 100644
--- a/libssh2-sys/Cargo.toml
+++ b/libssh2-sys/Cargo.toml
@@ -16,6 +16,9 @@ path = "lib.rs"
libz-sys = ">= 0"
libc = "0.2"
+[target."cfg(unix)".dependencies]
+openssl-sys = ">= 0"
+
[target.i686-apple-darwin.dependencies]
openssl-sys = ">= 0"
[target.x86_64-apple-darwin.dependencies]