summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorWez Furlong <wez@wezfurlong.org>2019-07-24 15:00:20 -0700
committerWez Furlong <wez@wezfurlong.org>2019-07-29 08:49:22 -0700
commit78d2e3d9dbf1530cdf4bc152b91f0ddd7ce4895b (patch)
treeb1eef8bf39a3948f275f62b7d2b800fe937aeabb /Cargo.toml
parent31c39b05337590c3f64dac265a0e6dbba53f7e91 (diff)
downloadssh2-rs-78d2e3d9dbf1530cdf4bc152b91f0ddd7ce4895b.zip
libssh2-sys: add `vendored-openssl` feature to build openssl-src
This enables building `ssh2` and `libssh2-sys` with the `vendored-openssl` feature, which in turn causes openssl to be built and linked locally, and does not require that homebrew or some other externally provided version of openssl be made available. It does require a working C compiler, perl and make.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d10e542..8745af2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,6 +13,9 @@ Bindings to libssh2 for interacting with SSH servers and executing remote
commands, forwarding local ports, etc.
"""
+[features]
+vendored-openssl = ["libssh2-sys/vendored-openssl"]
+
[dependencies]
bitflags = "1.0.4"
libc = "0.2"