summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorWez Furlong <wez@wezfurlong.org>2019-07-29 14:03:34 -0700
committerWez Furlong <wez@wezfurlong.org>2019-07-31 14:21:50 -0700
commit3aa8096bc4e1c6c762f8553c516b5ce099ba5f71 (patch)
tree87daf4fefb6814697e8ac7309e5892456cfc7e6b /Cargo.toml
parentff790796728ed74ff29cded408622117ebf0e64f (diff)
downloadssh2-rs-3aa8096bc4e1c6c762f8553c516b5ce099ba5f71.zip
Fix scp_recv ABI issue on Windows
* Adopt scp_recv2 instead, which uses compatible 64-bit stat types * Mark scp_recv as deprecated * small version bump Fixes https://github.com/alexcrichton/ssh2-rs/issues/109 Refs https://github.com/alexcrichton/ssh2-rs/pull/117 Co-authored-by: Joyce Babu <joyce@ennexa.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5f93fcc..731ebb1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ vendored-openssl = ["libssh2-sys/vendored-openssl"]
[dependencies]
bitflags = "1.0.4"
libc = "0.2"
-libssh2-sys = { path = "libssh2-sys", version = "0.2.4" }
+libssh2-sys = { path = "libssh2-sys", version = "0.2.12" }
[dev-dependencies]
tempdir = "0.3"