summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2014-10-27 22:59:45 -0700
committerAlex Crichton <alex@alexcrichton.com>2014-10-27 22:59:45 -0700
commit05f38137a16dc86f3220acbcc9f39dae3c4d828a (patch)
tree5a1939ad0a899f44ddb18e8154f418cbd17da3c6 /Cargo.toml
parente39af0ae680a956541a225c3146d16693c438c26 (diff)
downloadssh2-rs-05f38137a16dc86f3220acbcc9f39dae3c4d828a.zip
Add some manifest metadata
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 15 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ad3e4fe..d2aef00 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,10 +1,20 @@
[package]
- name = "ssh2"
- version = "0.0.1"
- authors = ["Alex Crichton <alex@alexcrichton.com>"]
+name = "ssh2"
+version = "0.0.1"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+license = "MIT/APL2"
+keywords = ["ssh", "encoding"]
+repository = "https://github.com/alexcrichton/ssh2-rs"
+homepage = "https://github.com/alexcrichton/ssh2-rs"
+documentation = "http://alexcrichton.com/ssh2-rs"
+description = """
+Bindings to libssh2 for interacting with SSH servers and executing remote
+commands, forwarding local ports, etc.
+"""
[[test]]
- name = "all"
+name = "all"
[dependencies.libssh2-sys]
- path = "libssh2-sys"
+path = "libssh2-sys"
+version = "*"