summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJérémie Courrèges-Anglas <jca@wxcvbn.org>2013-11-26 11:35:50 +0100
committerJérémie Courrèges-Anglas <jca@wxcvbn.org>2013-11-26 11:35:50 +0100
commitc7b673ef8bebc39d336667a55bd5f36b9b14cbf7 (patch)
treefa1c576318c7695a5ad6ca2727d9d7cd22fb4d16 /configure.ac
parentd246050de440fae1a7b3eae50c18eca9d41cdda5 (diff)
downloadratpoison-c7b673ef8bebc39d336667a55bd5f36b9b14cbf7.zip
Prettify --enable-debug handling.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index dc8dd02..1707720 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,15 +31,12 @@ AM_MAINTAINER_MODE([enable])
AC_CONFIG_HEADER(src/config.h)
dnl by default turn off debugging
-AC_MSG_CHECKING(whether to enable debugging)
-AC_ARG_ENABLE(debug,AS_HELP_STRING([--enable-debug],[build with extra debugging messages]),
- [if test "x$enableval" != "xno"; then
- AC_DEFINE_UNQUOTED(DEBUG, 1, Define this to enable debugging messages)
- AC_MSG_RESULT(yes)
- CFLAGS="$CFLAGS -g"
- else
- AC_MSG_RESULT(no)
- fi],[AC_MSG_RESULT(no)])
+AC_MSG_CHECKING([whether to enable debugging])
+AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],[build with extra debugging messages])],
+ [AC_MSG_RESULT([yes])
+ AC_DEFINE([DEBUG], 1, [Define this to enable debugging messages])],
+ [AC_MSG_RESULT([no])])
AC_ARG_WITH([electric-fence],
[AS_HELP_STRING([--with-electric-fence],