summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJilles Tjoelker <jilles@irssi.org>2009-04-26 20:54:49 +0000
committerjilles <jilles@dbcabf3a-b0e7-0310-adc4-f8d773084564>2009-04-26 20:54:49 +0000
commit545ae83d0789b82468503177ee5ac075e9482a57 (patch)
tree5cf03b16239aaebe73335addf632dbf89ea32741 /Makefile.am
parent3400958570dc1c8dfd92add21852e4caebf96004 (diff)
downloadirssi-545ae83d0789b82468503177ee5ac075e9482a57.zip
Fix make install without write privilege to the source directory
by not using a temp file in there for irssi-version.h. Note that this will still not work if the source has changed since it was compiled, but that is to be expected. git-svn-id: file:///var/www/svn.irssi.org/SVN/irssi/trunk@5062 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d8b54d72..158b7619 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,9 +10,7 @@ default-config.h: $(srcdir)/irssi.conf
default-theme.h: $(srcdir)/default.theme
$(srcdir)/file2header.sh $(srcdir)/default.theme default_theme > default-theme.h
irssi-version.h:
- $(srcdir)/irssi-version.sh $(srcdir) > $@.tmp
- cmp -s $@.tmp $@ || mv $@.tmp $@
- rm -f $@.tmp
+ $(srcdir)/irssi-version.sh $(srcdir) | cmp -s - $@ || $(srcdir)/irssi-version.sh $(srcdir) >$@
SUBDIRS = src docs scripts