summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTobias Mueller <tobiasmue@gnome.org>2014-01-07 00:39:52 +0100
committerTobias Mueller <tobiasmue@gnome.org>2014-01-07 00:39:52 +0100
commitec640e1dcccd82f604a9a0bf265a3ae7650b2139 (patch)
tree194f2f67587fd43fbd94608a46ef25ec6d079316 /setup.py
parentd3accd8256cad55aec8d8836ca965582b2608378 (diff)
downloadcalendar-cli-ec640e1dcccd82f604a9a0bf265a3ae7650b2139.zip
Created a setup.py to allow installation via pip
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py52
1 files changed, 52 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..9fecdd9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,52 @@
+#!/usr/bin/env python
+
+import sys
+import os
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+
+setup(
+ name='calendar-cli',
+ version='0.1',
+ description='Simple command-line CalDav client, for adding and browsing calendar items, todo list items, etc.',
+ url='https://github.com/tobixen/calendar-cli',
+ #packages=['',
+ # ],
+ license='GPLv3+',
+ author='Tobias Brox',
+ author_email='t-calendar-cli@tobixen.no',
+ classifiers=[
+ #"Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ #"License :: OSI Approved :: Apache Software License",
+ "Operating System :: POSIX",
+ "Programming Language :: Python",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content :: CGI Tools/Libraries",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+ scripts=['calendar-cli.py'],
+ dependency_links = [
+ # The package doesn't seem to be on pypi.
+ # We assume a low version number in case it gets uploaded
+ # so that the higher version is chosen over the git version
+ #
+ # There is a mirror here:
+ 'https://github.com/skarra/CalDAVClientLibrary/tarball/master#egg=caldavclientlibrary-0.0.1',
+ 'git+https://github.com/skarra/CalDAVClientLibrary.git#egg=caldavclientlibrary-0.0.1',
+ # We should prefer the official SVN
+ 'svn+http://svn.calendarserver.org/repository/calendarserver/CalDAVClientLibrary/trunk#egg=caldavclientlibrary-0.0.2',
+ # But there is an issue with the upstream setup.py, it does not have a name=''
+ # So we load the patched version
+ 'git+https://github.com/muelli/CalDAVClientLibrary.git#egg=caldavclientlibrary-0.0.3',
+ ],
+ install_requires=[
+ 'icalendar',
+ 'caldavclientlibrary',
+ ],
+)