summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTobias Brox <tobias@redpill-linpro.com>2022-10-28 13:11:58 +0200
committerTobias Brox <tobias@redpill-linpro.com>2022-10-28 13:28:07 +0200
commite32ed93dd4ed31a22637209f2735ac19098c9bcf (patch)
treea23ed8aadc739439cb3f797bc21cff1e7d0d6dbf /setup.py
parente2776738050f226dbea7d2e6e6783efba8bcbf6a (diff)
downloadcalendar-cli-e32ed93dd4ed31a22637209f2735ac19098c9bcf.zip
bugfix - setup.py imported calendar-cli to check for metadata, this broke due to missing dependencies. metadata now pushed out in a separate file
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 0d91b62..afff7e5 100644
--- a/setup.py
+++ b/setup.py
@@ -5,12 +5,11 @@ import os
from setuptools import setup, find_packages
-import calendar_cli as my_script
+import metadata
-metadata = {}
+metadata_ = {}
for attribute in ('version', 'author', 'author_email', 'license'):
- if hasattr(my_script, '__%s__' % attribute):
- metadata[attribute] = getattr(my_script, '__%s__' % attribute)
+ metadata_[attribute] = getattr(metadata, '__%s__' % attribute)
setup(
name='calendar-cli',
@@ -32,7 +31,7 @@ setup(
py_modules=['cal'],
install_requires=[
'icalendar',
- 'caldav>=0.10.0dev',
+ 'caldav>=0.10',
# 'isodate',
'pytz', ## pytz is supposed to be obsoleted, but see https://github.com/collective/icalendar/issues/333
'tzlocal',
@@ -44,5 +43,5 @@ setup(
'kal = cal:cli',
],
},
- **metadata
+ **metadata_
)