summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTobias Brox <tobias@redpill-linpro.com>2022-10-28 17:48:11 +0200
committerTobias Brox <tobias@redpill-linpro.com>2022-10-28 17:48:36 +0200
commit0400ad1717f9418b65731524d7af7a86867d8e52 (patch)
treed72efb97768fc15849c83320a0b4e41aec57a447 /setup.py
parent60895dc06388ef1396e0353816adff92456941b9 (diff)
downloadcalendar-cli-0400ad1717f9418b65731524d7af7a86867d8e52.zip
Bugfix. I broke setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 6 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index afff7e5..d73f69c 100644
--- a/setup.py
+++ b/setup.py
@@ -5,16 +5,15 @@ import os
from setuptools import setup, find_packages
-import metadata
+from metadata import metadata
+metadata_ = metadata.copy()
-metadata_ = {}
-for attribute in ('version', 'author', 'author_email', 'license'):
- metadata_[attribute] = getattr(metadata, '__%s__' % attribute)
+for x in metadata:
+ if not x in ('author', 'version', 'license', 'maintainer', 'author_email',
+ 'status', 'name', 'description', 'url', 'description'):
+ metadata_.pop(x)
setup(
- name='calendar-cli',
- description='Simple command-line CalDav client, for adding and browsing calendar items, todo list items, etc.',
- url='https://github.com/tobixen/calendar-cli',
#packages=['',
# ],
classifiers=[