summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcos <cos>2024-04-08 16:52:58 +0200
committercos <cos>2024-04-08 17:18:25 +0200
commitef9844586225170a2023d298745f96655ddeb3d8 (patch)
treee815e897e05ff116b8ab4a1752565883e50ad54e
parent6c00d89d9454ff49963d2db110d18b2dc2fb951a (diff)
downloadcalendar-cli-debian/latest.zip
Add initial files for debian packagingdebian/latest
-rw-r--r--debian/calendar-cli-docs.docs1
-rw-r--r--debian/changelog5
-rw-r--r--debian/control40
-rw-r--r--debian/copyright33
-rwxr-xr-xdebian/rules26
5 files changed, 105 insertions, 0 deletions
diff --git a/debian/calendar-cli-docs.docs b/debian/calendar-cli-docs.docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/calendar-cli-docs.docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..aa43a17
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+calendar-cli (1.0.1-1) UNRELEASED; urgency=medium
+
+ * Initial release.
+
+ -- cos <cos> Mon, 08 Apr 2024 16:33:28 +0200
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..4ed51d0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,40 @@
+Source: calendar-cli
+Section: net
+Priority: optional
+Maintainer: cos <cos>
+Rules-Requires-Root: no
+Build-Depends:
+ debhelper-compat (= 13),
+ python3,
+ python3-pytest,
+Standards-Version: 4.6.2
+Homepage: https://github.com/tobixen/calendar-cli
+Vcs-Browser: https://git.netizen.se/calendar-cli
+Vcs-Git: https://git.netizen.se/calendar-cli
+
+Package: calendar-cli
+Architecture: all
+Multi-Arch: foreign
+Depends:
+ ${misc:Depends},
+ python3-caldav (>=0.12),
+ python3-icalendar,
+ python3-pytz-deprecation-shim,
+ python3-tzlocal,
+ python3-Click,
+ python3-six,
+Description: Simple command-line CalDav client
+ With calendar-cli it is possible to add calendar events, browse an agenda and
+ do task management using a caldav server.
+ .
+ THIS IS THE LEGACY VERSION. If you're already using calendar-cli and don't
+ want to change anything, then keep using it. If you need a production-ready
+ mature command-line utility for accessing your calendar, then this is the
+ right tool ... as for now. I decided to change a bit on the user interface,
+ rather than breaking backward compatibility I made a new command name plann. I
+ would recommend visit https://github.com/tobixen/plann for the new version.
+ .
+ This command, calendar-cli, will be maintained primarily for backward
+ compatibility. Bugfixes or minor "missing" features will be considered - but
+ for anyone in need of a command-line interface towards a CalDAV calendar
+ server, the recommendation is to use plann instead.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..1942b04
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,33 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Source: https://github.com/tobixen/calendar-cli
+Upstream-Name: calendar-cli
+Upstream-Contact: calendar-cli <t-calendar-cli@tobixen.no>
+
+Files:
+ *
+Copyright:
+ 2013-2024 Tobias Brox <tobias@redpill-linpro.com>
+License: GPL-3.0+
+
+Files:
+ debian/*
+Copyright:
+ 2024 cos <cos>
+License: GPL-3.0+
+
+License: GPL-3.0+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <https://www.gnu.org/licenses/>.
+Comment:
+ On Debian systems, the complete text of the GNU General
+ Public License version 3 can be found in "/usr/share/common-licenses/GPL-3".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..92175b6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,26 @@
+#!/usr/bin/make -f
+
+# See debhelper(7) (uncomment to enable).
+# Output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+
+
+# See FEATURE AREAS in dpkg-buildflags(1).
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# See ENVIRONMENT in dpkg-buildflags(1).
+# Package maintainers to append CFLAGS.
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# Package maintainers to append LDFLAGS.
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+
+# dh_make generated override targets.
+# This is an example for Cmake (see <https://bugs.debian.org/641051>).
+#override_dh_auto_configure:
+# dh_auto_configure -- \
+# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)