summaryrefslogtreecommitdiff
path: root/weechat/src/plugins/scripts/ruby/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'weechat/src/plugins/scripts/ruby/CMakeLists.txt')
-rw-r--r--weechat/src/plugins/scripts/ruby/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/weechat/src/plugins/scripts/ruby/CMakeLists.txt b/weechat/src/plugins/scripts/ruby/CMakeLists.txt
deleted file mode 100644
index 257aa00cd..000000000
--- a/weechat/src/plugins/scripts/ruby/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-
-ADD_LIBRARY(ruby MODULE weechat-ruby.c)
-
-SET_TARGET_PROPERTIES(ruby PROPERTIES PREFIX "")
-
-IF(RUBY_FOUND)
- INCLUDE_DIRECTORIES(${RUBY_INCLUDE_PATH})
- TARGET_LINK_LIBRARIES(ruby ${RUBY_LIBRARY} weechat_scripts)
-ENDIF(RUBY_FOUND)
-
-INSTALL(TARGETS ruby LIBRARY DESTINATION lib/${PROJECT_NAME}/plugins)