summaryrefslogtreecommitdiff
path: root/src/plugins/scripts/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/scripts/perl/Makefile.am')
-rw-r--r--src/plugins/scripts/perl/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/plugins/scripts/perl/Makefile.am b/src/plugins/scripts/perl/Makefile.am
new file mode 100644
index 000000000..1327bab98
--- /dev/null
+++ b/src/plugins/scripts/perl/Makefile.am
@@ -0,0 +1,26 @@
+# Copyright (c) 2003-2005 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(PERL_CFLAGS)
+
+libdir = ${weechat_libdir}/plugins
+
+lib_LTLIBRARIES = libperl.la
+
+libperl_la_SOURCES = weechat-perl.c
+libperl_la_LDFLAGS = -module
+libperl_la_LIBADD = ../lib_weechat_plugins_scripts.la $(PERL_LFLAGS)