summaryrefslogtreecommitdiff
path: root/src/plugins/ruby/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/ruby/CMakeLists.txt')
-rw-r--r--src/plugins/ruby/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/ruby/CMakeLists.txt b/src/plugins/ruby/CMakeLists.txt
new file mode 100644
index 000000000..5f2aa86ee
--- /dev/null
+++ b/src/plugins/ruby/CMakeLists.txt
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2003-2012 Sebastien Helleu <flashcode@flashtux.org>
+#
+# This file is part of WeeChat, the extensible chat client.
+#
+# WeeChat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# WeeChat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
+#
+
+ADD_LIBRARY(ruby MODULE weechat-ruby.c weechat-ruby.h weechat-ruby-api.c
+weechat-ruby-api.h)
+
+SET_TARGET_PROPERTIES(ruby PROPERTIES PREFIX "")
+
+IF(RUBY_FOUND)
+ INCLUDE_DIRECTORIES(${RUBY_INCLUDE_PATH} ${RUBY_ARCH})
+ TARGET_LINK_LIBRARIES(ruby ${RUBY_LIBRARY} weechat_plugins_scripts)
+ENDIF(RUBY_FOUND)
+
+INSTALL(TARGETS ruby LIBRARY DESTINATION ${LIBDIR}/plugins)