summaryrefslogtreecommitdiff
path: root/src/plugins/relay/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/relay/CMakeLists.txt')
-rw-r--r--src/plugins/relay/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/plugins/relay/CMakeLists.txt b/src/plugins/relay/CMakeLists.txt
index 451a54030..57e123074 100644
--- a/src/plugins/relay/CMakeLists.txt
+++ b/src/plugins/relay/CMakeLists.txt
@@ -43,13 +43,16 @@ set_target_properties(relay PROPERTIES PREFIX "")
set(LINK_LIBS)
-list(APPEND LINK_LIBS ${ZLIB_LIBRARY})
-
include_directories(${GNUTLS_INCLUDE_PATH})
list(APPEND LINK_LIBS ${GNUTLS_LIBRARY})
list(APPEND LINK_LIBS ${GCRYPT_LDFLAGS})
+list(APPEND LINK_LIBS ${ZLIB_LIBRARY})
+
+include_directories(${ZSTD_INCLUDE_DIRS})
+list(APPEND LINK_LIBS ${LIBZSTD_LDFLAGS})
+
target_link_libraries(relay ${LINK_LIBS} coverage_config)
install(TARGETS relay LIBRARY DESTINATION ${WEECHAT_LIBDIR}/plugins)