summaryrefslogtreecommitdiff
path: root/src/plugins/fset/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/fset/Makefile.am')
-rw-r--r--src/plugins/fset/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/src/plugins/fset/Makefile.am b/src/plugins/fset/Makefile.am
new file mode 100644
index 000000000..5121614f6
--- /dev/null
+++ b/src/plugins/fset/Makefile.am
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2003-2017 Sébastien Helleu <flashcode@flashtux.org>
+#
+# This file is part of WeeChat, the extensible chat client.
+#
+# WeeChat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# WeeChat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
+#
+
+AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(FSET_CFLAGS)
+
+libdir = ${weechat_libdir}/plugins
+
+lib_LTLIBRARIES = fset.la
+
+fset_la_SOURCES = fset.c \
+ fset.h \
+ fset-bar-item.c \
+ fset-bar-item.h \
+ fset-buffer.c \
+ fset-buffer.h \
+ fset-command.c \
+ fset-command.h \
+ fset-config.c \
+ fset-config.h \
+ fset-info.c \
+ fset-info.h \
+ fset-mouse.c \
+ fset-mouse.h \
+ fset-option.c \
+ fset-option.h
+
+fset_la_LDFLAGS = -module -no-undefined
+fset_la_LIBADD = $(FSET_LFLAGS)
+
+EXTRA_DIST = CMakeLists.txt