summaryrefslogtreecommitdiff
path: root/src/gui/wxwidgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/wxwidgets/Makefile.am')
-rw-r--r--src/gui/wxwidgets/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/gui/wxwidgets/Makefile.am b/src/gui/wxwidgets/Makefile.am
new file mode 100644
index 000000000..bdfca7f5a
--- /dev/null
+++ b/src/gui/wxwidgets/Makefile.am
@@ -0,0 +1,29 @@
+# Copyright (c) 2003-2005 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\"
+
+bin_PROGRAMS = weechat-wxwidgets
+
+weechat_wxwidgets_LDADD = ../lib_weechat_gui_common.a \
+ ../../common/lib_weechat_main.a \
+ ../../irc/lib_weechat_irc.a \
+ $(WXWIDGETS_LIBS) \
+ ../../plugins/lib_weechat_plugins.a $(PLUGINS_LIBS)
+
+weechat_wxwidgets_SOURCES = gui-display.c \
+ gui-input.c