summaryrefslogtreecommitdiff
path: root/src/gui/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/gtk/Makefile.am')
-rw-r--r--src/gui/gtk/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/gui/gtk/Makefile.am b/src/gui/gtk/Makefile.am
index f89bd7b5a..addc5bf08 100644
--- a/src/gui/gtk/Makefile.am
+++ b/src/gui/gtk/Makefile.am
@@ -19,12 +19,11 @@ INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(GTK_CFLAGS)
bin_PROGRAMS = weechat-gtk
-weechat_gtk_LDADD = ../../common/lib_weechat_main.a \
+weechat_gtk_LDADD = ../lib_weechat_gui_common.a \
+ ../../common/lib_weechat_main.a \
../../irc/lib_weechat_irc.a \
$(GTK_LIBS) \
../../plugins/lib_weechat_plugins.a $(PLUGINS_LIBS)
-weechat_gtk_SOURCES = ../gui.h \
- ../gui-common.c \
- gui-display.c \
+weechat_gtk_SOURCES = gui-display.c \
gui-input.c