summaryrefslogtreecommitdiff
path: root/src/gui/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/gtk/Makefile.am')
-rw-r--r--src/gui/gtk/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/src/gui/gtk/Makefile.am b/src/gui/gtk/Makefile.am
index 10b5ed4d3..655a03d40 100644
--- a/src/gui/gtk/Makefile.am
+++ b/src/gui/gtk/Makefile.am
@@ -19,11 +19,24 @@ INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(GTK_CFLAGS)
bin_PROGRAMS = weechat-gtk
-weechat_gtk_LDADD = ../lib_weechat_gui_common.a \
+if PLUGINS
+weechat_gtk_LDADD = ../gui-common.o ../gui-keyboard.o \
+ ../gui-action.o \
../../common/lib_weechat_main.a \
../../irc/lib_weechat_irc.a \
+ ../../plugins/lib_weechat_plugins.a \
+ $(PLUGINS_LIBS) \
$(GTK_LIBS) \
- ../../plugins/lib_weechat_plugins.a $(PLUGINS_LIBS)
+ $(GNUTLS_LFLAGS)
+else
+weechat_gtk_LDADD = ../gui-common.o ../gui-keyboard.o \
+ ../gui-action.o \
+ ../../common/lib_weechat_main.a \
+ ../../irc/lib_weechat_irc.a \
+ $(PLUGINS_LIBS) \
+ $(GTK_LIBS) \
+ $(GNUTLS_LFLAGS)
+endif
weechat_gtk_SOURCES = gui-display.c \
- gui-input.c
+ gui-input.c