summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
new file mode 100644
index 000000000..ca0701c73
--- /dev/null
+++ b/src/core/Makefile.am
@@ -0,0 +1,48 @@
+# Copyright (c) 2003-2007 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(GNUTLS_CFLAGS)
+
+noinst_LIBRARIES = lib_weechat_main.a
+
+lib_weechat_main_a_SOURCES = weechat.c \
+ weechat.h \
+ alias.c \
+ alias.h \
+ backtrace.c \
+ backtrace.h \
+ command.c \
+ command.h \
+ completion.c \
+ completion.h \
+ weelist.c \
+ weelist.h \
+ weeconfig.c \
+ weeconfig.h \
+ history.c \
+ history.h \
+ hotlist.c \
+ hotlist.h \
+ log.c \
+ log.h \
+ fifo.c \
+ fifo.h \
+ session.c \
+ session.h \
+ utf8.c \
+ utf8.h \
+ util.c \
+ util.h