summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/weechat-curses.install6
-rw-r--r--debian/weechat-curses.lintian-overrides1
-rw-r--r--debian/weechat-curses.menu4
4 files changed, 12 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index f9af7b743..284373bd4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,6 +26,13 @@ $(BUILDDIR)/Makefile:
override_dh_auto_build: $(BUILDDIR)/Makefile
dh_auto_build
+# Create a symbolic link weechat -> weechat-curses
+# This link is created for compatibility with old versions on /upgrade.
+# It may be removed in future.
+override_dh_auto_install:
+ dh_auto_install
+ ln -s weechat $(CURDIR)/debian/weechat-curses/usr/bin/weechat-curses
+
override_dh_auto_configure:
# the package also has autotools buildsys and
# debhelper try to use it but that's not needed
diff --git a/debian/weechat-curses.install b/debian/weechat-curses.install
index a9c211f8b..9ca632180 100644
--- a/debian/weechat-curses.install
+++ b/debian/weechat-curses.install
@@ -1,4 +1,4 @@
-usr/bin/weechat-curses
+usr/bin/weechat
debian/weechat.xpm usr/share/pixmaps
-usr/share/man/man1/weechat-curses.1
-usr/share/man/*/man1/weechat-curses.1
+usr/share/man/man1/weechat.1
+usr/share/man/*/man1/weechat.1
diff --git a/debian/weechat-curses.lintian-overrides b/debian/weechat-curses.lintian-overrides
deleted file mode 100644
index b1c6ca402..000000000
--- a/debian/weechat-curses.lintian-overrides
+++ /dev/null
@@ -1 +0,0 @@
-weechat-curses: manpage-has-errors-from-man usr/share/man/man1/weechat-curses.1.gz 65: warning [p 1, 9.7i]: cannot adjust line
diff --git a/debian/weechat-curses.menu b/debian/weechat-curses.menu
index 5c5f5f994..0cd91687c 100644
--- a/debian/weechat-curses.menu
+++ b/debian/weechat-curses.menu
@@ -1,4 +1,4 @@
?package(weechat-curses):needs="text" section="Applications/Network/Communication" \
- title="weechat-curses" \
+ title="weechat" \
icon="/usr/share/pixmaps/weechat.xpm" \
- command="/usr/bin/weechat-curses"
+ command="/usr/bin/weechat"