summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 1 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index be8359c35..661c80bbc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,6 @@
# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
-CFLAGS = -Wall -g
-
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
@@ -43,6 +41,7 @@ install: build
dh_clean -k
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/weechat
+ dh_install --sourcedir=debian/weechat
install -o root -g root -m 755 src/gui/curses/weechat-curses $(CURDIR)/debian/weechat-curses/usr/bin
install -o root -g root -m 755 src/gui/gtk/weechat-gtk $(CURDIR)/debian/weechat-gtk/usr/bin