summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 12 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 46ade8c11..a7f12988d 100644
--- a/configure.in
+++ b/configure.in
@@ -84,11 +84,11 @@ AH_VERBATIM([WEECHAT_LIBDIR], [#undef WEECHAT_LIBDIR])
AH_VERBATIM([WEECHAT_SHAREDIR], [#undef WEECHAT_SHAREDIR])
AH_VERBATIM([PLUGINS], [#undef PLUGINS])
AH_VERBATIM([PLUGIN_PERL], [#undef PLUGIN_PERL])
+AH_VERBATIM([PERL_NOTHREAD], [#undef PERL_NOTHREAD])
AH_VERBATIM([PLUGIN_PYTHON], [#undef PLUGIN_PYTHON])
AH_VERBATIM([PLUGIN_RUBY], [#undef PLUGIN_RUBY])
AH_VERBATIM([HAVE_GNUTLS], [#undef HAVE_GNUTLS])
AH_VERBATIM([DEBUG], [#undef DEBUG])
-AH_VERBATIM([PERL_NOTHREAD], [#undef PERL_NOTHREAD])
# Arguments for ./configure
@@ -104,15 +104,15 @@ AC_ARG_ENABLE(ruby, [ --enable-ruby Turn on Ruby script plug
AC_ARG_ENABLE(gnutls, [ --disable-gnutls Turn off gnutls support (default=compiled if found)],enable_gnutls=$enableval,enable_gnutls=yes)
AC_ARG_WITH(debug, [ --with-debug Debugging: 0=no debug, 1=debug compilation, 2=debug compilation + verbose msgs (default=0)],debug=$withval,debug=0)
-AM_CONDITIONAL(GUI_NCURSES, test "$enable_ncurses" = "yes")
-AM_CONDITIONAL(GUI_WXWIDGETS, test "$enable_wxwidgets" = "yes")
-AM_CONDITIONAL(GUI_GTK, test "$enable_gtk" = "yes")
-AM_CONDITIONAL(GUI_QT, test "$enable_qt" = "yes")
-AM_CONDITIONAL(PLUGINS, test "$enable_plugins" = "yes")
-AM_CONDITIONAL(PLUGIN_PERL, test "$enable_perl" = "yes")
-AM_CONDITIONAL(PLUGIN_PYTHON, test "$enable_python" = "yes")
-AM_CONDITIONAL(PLUGIN_RUBY, test "$enable_ruby" = "yes")
-AM_CONDITIONAL(HAVE_GNUTLS, test "$enable_gnutls" = "yes")
+AM_CONDITIONAL(GUI_NCURSES, test "$enable_ncurses" = "yes")
+AM_CONDITIONAL(GUI_WXWIDGETS, test "$enable_wxwidgets" = "yes")
+AM_CONDITIONAL(GUI_GTK, test "$enable_gtk" = "yes")
+AM_CONDITIONAL(GUI_QT, test "$enable_qt" = "yes")
+AM_CONDITIONAL(PLUGINS, test "$enable_plugins" = "yes")
+AM_CONDITIONAL(PLUGIN_PERL, test "$enable_perl" = "yes" -o "$enable_perl_nothread" = "yes")
+AM_CONDITIONAL(PLUGIN_PYTHON, test "$enable_python" = "yes")
+AM_CONDITIONAL(PLUGIN_RUBY, test "$enable_ruby" = "yes")
+AM_CONDITIONAL(HAVE_GNUTLS, test "$enable_gnutls" = "yes")
# ------------------------------------------------------------------------------
# GUI
@@ -177,8 +177,9 @@ fi
PLUGINS_LIBS=
-if test "x$enable_perl_nothread" = "xyes" ; then
+if test "x$enable_perl_nothread" = "xyes" ; then
enable_perl="yes"
+ AC_DEFINE(PERL_NOTHREAD)
fi
if test "x$enable_perl" = "xyes" ; then
@@ -328,10 +329,6 @@ fi
# general vars
# ------------------------------------------------------------------------------
-if test "x$enable_perl_nothread" = "xyes" ; then
- AC_DEFINE(PERL_NOTHREAD)
-fi
-
if test "x$prefix" = "xNONE" ; then
prefix="$ac_default_prefix"
fi