summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2022-02-21 20:17:01 +0100
committerSébastien Helleu <flashcode@flashtux.org>2022-02-21 20:17:01 +0100
commitfd27faf89989498ef43f47866c85d482ff5241e8 (patch)
tree8c4b1900a5e6f741afe0dde53e73b1be9ea1d87c /tests/Makefile.am
parent7486ea6dc11a50a3fec3c728f93b71bf83805e41 (diff)
downloadweechat-fd27faf89989498ef43f47866c85d482ff5241e8.zip
tests: add tests on function logger_backlog_display_line
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0519fa31a..9d4f7650a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -84,6 +84,10 @@ tests_irc = unit/plugins/irc/test-irc-buffer.cpp \
unit/plugins/irc/test-irc-tag.cpp
endif
+if PLUGIN_LOGGER
+tests_logger = unit/plugins/logger/test-logger-backlog.cpp
+endif
+
if PLUGIN_RELAY
tests_relay = unit/plugins/relay/test-relay-auth.cpp
endif
@@ -100,6 +104,7 @@ endif
lib_weechat_unit_tests_plugins_la_SOURCES = unit/plugins/test-plugins.cpp \
$(tests_irc) \
+ $(tests_logger) \
$(tests_relay) \
$(tests_trigger) \
$(tests_typing)