summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-05-21 14:54:02 +0200
committerSébastien Helleu <flashcode@flashtux.org>2023-05-22 20:43:16 +0200
commiteb7435f8b9e2bf29e5a23736a122b6713d3cf6d3 (patch)
tree35fbf773acfbe3d30b1ef522d1706820a60f8428 /tests/CMakeLists.txt
parent126d3559ca24c7a298b0c20f685dc7fd7badd76d (diff)
downloadweechat-eb7435f8b9e2bf29e5a23736a122b6713d3cf6d3.zip
tests: separate prefix from message in recorded messages
The record functions are moved to tests-record.cpp.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 51c65e1cb..46cea3a35 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -135,7 +135,10 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
endif()
# binary to run tests
-set(WEECHAT_TESTS_SRC tests.cpp tests.h)
+set(WEECHAT_TESTS_SRC
+ tests.cpp tests.h
+ tests-record.cpp tests-record.h
+)
add_executable(tests ${WEECHAT_TESTS_SRC})
target_link_libraries(tests
weechat_core