summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2024-01-14 10:24:41 +0100
committerSébastien Helleu <flashcode@flashtux.org>2024-02-01 21:38:53 +0100
commit6cfb31c306b9deb120a9fb5c564a1456a72af665 (patch)
tree44b1cc7940b852d4fd215a5b269365b9652ac3ba /tests/CMakeLists.txt
parent8971fc069a1c1a9e8c3f6fa1f83e64a50b2876c1 (diff)
downloadweechat-6cfb31c306b9deb120a9fb5c564a1456a72af665.zip
relay: add support of websocket extension "permessage-deflate" (closes #1549)
This extension is used to compress and decompress websocket frames (using the DEFLATE algorithm, with zlib).
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 13574ba26..7a12de527 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -108,6 +108,7 @@ if (ENABLE_RELAY)
list(APPEND LIB_WEECHAT_UNIT_TESTS_PLUGINS_SRC
unit/plugins/relay/test-relay-auth.cpp
unit/plugins/relay/test-relay-http.cpp
+ unit/plugins/relay/test-relay-websocket.cpp
unit/plugins/relay/irc/test-relay-irc.cpp
)
endif()