summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2018-08-07 21:50:04 +0200
committerSébastien Helleu <flashcode@flashtux.org>2018-08-12 20:30:13 +0200
commit12a6f74ec01d9daa2e23dce5ab15b1ee3ce09006 (patch)
treeacf40a6fdbe99a8192c29408f130bdf900f12d2e /tests/CMakeLists.txt
parentd699ae89aa0ff818b6264ad17f62377f1753999d (diff)
downloadweechat-12a6f74ec01d9daa2e23dce5ab15b1ee3ce09006.zip
core: fix check of tags in lines
All changes: - fix check of tags in lines: check lines without tags, fix check of tags with negation ("!tag") - add string functions string_split_tags and string_free_split_tags - add tests on function gui_line_match_tags
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 8e87d894f..b90720498 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -35,6 +35,7 @@ set(LIB_WEECHAT_UNIT_TESTS_SRC
unit/core/test-url.cpp
unit/core/test-utf8.cpp
unit/core/test-util.cpp
+ unit/gui/test-line.cpp
scripts/test-scripts.cpp
)
add_library(weechat_unit_tests STATIC ${LIB_WEECHAT_UNIT_TESTS_SRC})