summaryrefslogtreecommitdiff
path: root/src/plugins/typing/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-01-06 13:10:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2023-01-08 14:19:41 +0100
commit754ab339469cdf8b55b82f4c896c4e15876551db (patch)
tree28a8a77c07a5e36e7af93ae0fe68a7a6416df239 /src/plugins/typing/Makefile.am
parent18360feb324d8d4f63706662b5c0e919bc93c357 (diff)
downloadweechat-754ab339469cdf8b55b82f4c896c4e15876551db.zip
core: remove build with autotools
CMake is now the only way to build WeeChat.
Diffstat (limited to 'src/plugins/typing/Makefile.am')
-rw-r--r--src/plugins/typing/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/src/plugins/typing/Makefile.am b/src/plugins/typing/Makefile.am
deleted file mode 100644
index 711e6152d..000000000
--- a/src/plugins/typing/Makefile.am
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2021-2023 Sébastien Helleu <flashcode@flashtux.org>
-#
-# This file is part of WeeChat, the extensible chat client.
-#
-# WeeChat is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# WeeChat is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with WeeChat. If not, see <https://www.gnu.org/licenses/>.
-#
-
-AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(TYPING_CFLAGS)
-
-libdir = ${weechat_libdir}/plugins
-
-lib_LTLIBRARIES = typing.la
-
-typing_la_SOURCES = typing.c \
- typing.h \
- typing-bar-item.c \
- typing-bar-item.h \
- typing-config.c \
- typing-config.h \
- typing-status.c \
- typing-status.h
-typing_la_LDFLAGS = -module -no-undefined
-typing_la_LIBADD = $(TYPING_LFLAGS)
-
-EXTRA_DIST = CMakeLists.txt