summaryrefslogtreecommitdiff
path: root/src/plugins/trigger/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2014-01-25 13:29:03 +0100
committerSebastien Helleu <flashcode@flashtux.org>2014-02-09 12:55:40 +0100
commit30942f7f62e47eec761a63ca4da7767859c82ce6 (patch)
treef95968f60adc8c8fb52d056c2d4dbb85d69db825 /src/plugins/trigger/CMakeLists.txt
parenta0bf3938f18c275fe585639db7ad9d945e462d94 (diff)
downloadweechat-30942f7f62e47eec761a63ca4da7767859c82ce6.zip
trigger: add trigger plugin
Diffstat (limited to 'src/plugins/trigger/CMakeLists.txt')
-rw-r--r--src/plugins/trigger/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/plugins/trigger/CMakeLists.txt b/src/plugins/trigger/CMakeLists.txt
new file mode 100644
index 000000000..59d8e1c00
--- /dev/null
+++ b/src/plugins/trigger/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2014 Sébastien Helleu <flashcode@flashtux.org>
+#
+# This file is part of WeeChat, the extensible chat client.
+#
+# WeeChat is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# WeeChat is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
+#
+
+ADD_LIBRARY(trigger MODULE
+trigger.c trigger.h
+trigger-buffer.c trigger-buffer.h
+trigger-callback.c trigger-callback.h
+trigger-command.c trigger-command.h
+trigger-completion.c trigger-completion.h
+trigger-config.c trigger-config.h)
+SET_TARGET_PROPERTIES(trigger PROPERTIES PREFIX "")
+
+TARGET_LINK_LIBRARIES(trigger)
+
+INSTALL(TARGETS trigger LIBRARY DESTINATION ${LIBDIR}/plugins)