summaryrefslogtreecommitdiff
path: root/src/plugins/spell/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2023-01-06 13:10:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2023-01-08 14:19:41 +0100
commit754ab339469cdf8b55b82f4c896c4e15876551db (patch)
tree28a8a77c07a5e36e7af93ae0fe68a7a6416df239 /src/plugins/spell/Makefile.am
parent18360feb324d8d4f63706662b5c0e919bc93c357 (diff)
downloadweechat-754ab339469cdf8b55b82f4c896c4e15876551db.zip
core: remove build with autotools
CMake is now the only way to build WeeChat.
Diffstat (limited to 'src/plugins/spell/Makefile.am')
-rw-r--r--src/plugins/spell/Makefile.am44
1 files changed, 0 insertions, 44 deletions
diff --git a/src/plugins/spell/Makefile.am b/src/plugins/spell/Makefile.am
deleted file mode 100644
index 4a081c008..000000000
--- a/src/plugins/spell/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2006 Emmanuel Bouthenot <kolter@openics.org>
-# Copyright (C) 2006-2023 Sébastien Helleu <flashcode@flashtux.org>
-#
-# This file is part of WeeChat, the extensible chat client.
-#
-# WeeChat is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or
-# (at your option) any later version.
-#
-# WeeChat is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with WeeChat. If not, see <https://www.gnu.org/licenses/>.
-#
-
-AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(ASPELL_CFLAGS) $(ENCHANT_CFLAGS)
-
-libdir = ${weechat_libdir}/plugins
-
-lib_LTLIBRARIES = spell.la
-
-spell_la_SOURCES = spell.c \
- spell.h \
- spell-bar-item.c \
- spell-bar-item.h \
- spell-command.c \
- spell-command.h \
- spell-completion.c \
- spell-completion.h \
- spell-config.c \
- spell-config.h \
- spell-info.c \
- spell-info.h \
- spell-speller.c \
- spell-speller.h
-spell_la_LDFLAGS = -module -no-undefined
-spell_la_LIBADD = $(ASPELL_LFLAGS) $(ENCHANT_LIBS)
-
-EXTRA_DIST = CMakeLists.txt