summaryrefslogtreecommitdiff
path: root/src/plugins/scripts/tcl/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2008-10-05 19:06:46 +0200
committerSebastien Helleu <flashcode@flashtux.org>2008-10-05 19:06:46 +0200
commit44944ef01ff2c0b81d4b6d6ce6d0f95ee6dd35a5 (patch)
tree4076ea07aa8ccf325842fa5525630e6e779f8ec4 /src/plugins/scripts/tcl/Makefile.am
parent269bf55b1ebd9a2342dd0e66af58f1d798652e7a (diff)
downloadweechat-44944ef01ff2c0b81d4b6d6ce6d0f95ee6dd35a5.zip
Add Tcl script plugin (thanks to Dmitry Kobylin)
Diffstat (limited to 'src/plugins/scripts/tcl/Makefile.am')
-rw-r--r--src/plugins/scripts/tcl/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/scripts/tcl/Makefile.am b/src/plugins/scripts/tcl/Makefile.am
new file mode 100644
index 000000000..f703760a2
--- /dev/null
+++ b/src/plugins/scripts/tcl/Makefile.am
@@ -0,0 +1,28 @@
+# Copyright (c) 2003-2008 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(TCL_CFLAGS)
+
+libdir = ${weechat_libdir}/plugins
+
+lib_LTLIBRARIES = tcl.la
+
+tcl_la_SOURCES = weechat-tcl.c \
+ weechat-tcl.h \
+ weechat-tcl-api.c \
+ weechat-tcl-api.h
+tcl_la_LDFLAGS = -module
+tcl_la_LIBADD = ../lib_weechat_plugins_scripts.la $(TCL_LFLAGS)