summaryrefslogtreecommitdiff
path: root/src/plugins/relay/Makefile.am
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2021-12-24 15:14:56 +0100
committerSébastien Helleu <flashcode@flashtux.org>2021-12-24 16:45:57 +0100
commit498194f6fc39ce96f17f5002aab7b0aa0a5e6f67 (patch)
tree80b2d9c1ec6b43fe86aacdf8e0e93c07232966a0 /src/plugins/relay/Makefile.am
parentd5c391b1ee57730ed6f94c3d7ee5661ceaff35f5 (diff)
downloadweechat-498194f6fc39ce96f17f5002aab7b0aa0a5e6f67.zip
relay: add zstd compression in weechat protocol
Option relay.network.compression_level is renamed to relay.network.compression and is now a percentage between 0 (no compression) to 100 (best compression, slowest). Compression is now disabled by default in weechat protocol and must be enabled via the `handshake` command (option `compression` has been removed from `init` command).
Diffstat (limited to 'src/plugins/relay/Makefile.am')
-rw-r--r--src/plugins/relay/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/relay/Makefile.am b/src/plugins/relay/Makefile.am
index 1fcee124f..c84d09569 100644
--- a/src/plugins/relay/Makefile.am
+++ b/src/plugins/relay/Makefile.am
@@ -17,7 +17,7 @@
# along with WeeChat. If not, see <https://www.gnu.org/licenses/>.
#
-AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(ZLIB_CFLAGS) $(GCRYPT_CFLAGS) $(GNUTLS_CFLAGS)
+AM_CPPFLAGS = -DLOCALEDIR=\"$(datadir)/locale\" $(GCRYPT_CFLAGS) $(GNUTLS_CFLAGS) $(ZLIB_CFLAGS) $(ZSTD_CFLAGS)
libdir = ${weechat_libdir}/plugins
@@ -61,6 +61,6 @@ relay_la_SOURCES = relay.c \
weechat/relay-weechat-protocol.h
relay_la_LDFLAGS = -module -no-undefined
-relay_la_LIBADD = $(RELAY_LFLAGS) $(ZLIB_LFLAGS) $(GCRYPT_LFLAGS) $(GNUTLS_LFLAGS)
+relay_la_LIBADD = $(RELAY_LFLAGS) $(GCRYPT_LFLAGS) $(GNUTLS_LFLAGS) $(ZLIB_LFLAGS) $(ZSTD_LFLAGS)
EXTRA_DIST = CMakeLists.txt