summaryrefslogtreecommitdiff
path: root/src/plugins/relay/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2008-12-10 17:08:56 +0100
committerSebastien Helleu <flashcode@flashtux.org>2008-12-10 17:08:56 +0100
commit20a1360bd87c9be583fd9fc540a8097ff2022781 (patch)
treeec6bea712338ab17a286f03c3334f1cd67aef6d5 /src/plugins/relay/Makefile.am
parent09fdd1ace3a888a13fb0f11d839c9bbbb09463e0 (diff)
downloadweechat-20a1360bd87c9be583fd9fc540a8097ff2022781.zip
Add new plugin "relay", new function "string_format_size" in plugin API
Diffstat (limited to 'src/plugins/relay/Makefile.am')
-rw-r--r--src/plugins/relay/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/plugins/relay/Makefile.am b/src/plugins/relay/Makefile.am
new file mode 100644
index 000000000..c2cf6e165
--- /dev/null
+++ b/src/plugins/relay/Makefile.am
@@ -0,0 +1,41 @@
+# Copyright (c) 2003-2008 FlashCode <flashcode@flashtux.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\"
+
+libdir = ${weechat_libdir}/plugins
+
+lib_LTLIBRARIES = relay.la
+
+relay_la_SOURCES = relay.c \
+ relay.h \
+ relay-buffer.c \
+ relay-buffer.h \
+ relay-client.c \
+ relay-client.h \
+ relay-command.c \
+ relay-command.h \
+ relay-config.c \
+ relay-config.h \
+ relay-info.c \
+ relay-info.h \
+ relay-network.c \
+ relay-network.h \
+ relay-upgrade.c \
+ relay-upgrade.h
+
+relau_la_LDFLAGS = -module
+relay_la_LIBADD = $(RELAY_LFLAGS)