summaryrefslogtreecommitdiff
path: root/src/plugins/relay/Makefile.am
diff options
context:
space:
mode:
authorSebastien Helleu <flashcode@flashtux.org>2011-12-06 23:06:23 +0100
committerSebastien Helleu <flashcode@flashtux.org>2011-12-06 23:06:23 +0100
commit013f8cc7570a283e4c265d2a03920ff60f681885 (patch)
treea81404bd4af44aef206b68a069e05b15ee6315a1 /src/plugins/relay/Makefile.am
parent00a3f990b3e512a7dc14343dd522a3a8497c4762 (diff)
downloadweechat-013f8cc7570a283e4c265d2a03920ff60f681885.zip
relay: add WeeChat protocol (for remote GUI), doc about protocol, new options
The protocol is partial, under development, and NOT ready for usage. New options added in relay.conf: - relay.network.allowed_ips: allow only some IPs on relay plugin (by default all IPs are allowed) - relay.network.compression_level: compression level used in WeeChat protocol (compression is made using zlib)
Diffstat (limited to 'src/plugins/relay/Makefile.am')
-rw-r--r--src/plugins/relay/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/plugins/relay/Makefile.am b/src/plugins/relay/Makefile.am
index da1620c5b..66656798f 100644
--- a/src/plugins/relay/Makefile.am
+++ b/src/plugins/relay/Makefile.am
@@ -17,7 +17,7 @@
# along with WeeChat. If not, see <http://www.gnu.org/licenses/>.
#
-INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\"
+INCLUDES = -DLOCALEDIR=\"$(datadir)/locale\" $(ZLIB_CFLAGS)
libdir = ${weechat_libdir}/plugins
@@ -29,10 +29,14 @@ relay_la_SOURCES = relay.c \
relay-buffer.h \
relay-client.c \
relay-client.h \
- relay-client-irc.c \
- relay-client-irc.h \
- relay-client-weechat.c \
- relay-client-weechat.h \
+ irc/relay-irc.c \
+ irc/relay-irc.h \
+ weechat/relay-weechat.c \
+ weechat/relay-weechat.h \
+ weechat/relay-weechat-msg.c \
+ weechat/relay-weechat-msg.h \
+ weechat/relay-weechat-protocol.c \
+ weechat/relay-weechat-protocol.h \
relay-command.c \
relay-command.h \
relay-completion.c \
@@ -49,6 +53,6 @@ relay_la_SOURCES = relay.c \
relay-upgrade.h
relay_la_LDFLAGS = -module
-relay_la_LIBADD = $(RELAY_LFLAGS)
+relay_la_LIBADD = $(RELAY_LFLAGS) $(ZLIB_LFLAGS)
EXTRA_DIST = CMakeLists.txt