summaryrefslogtreecommitdiff
path: root/src/plugins/python/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2019-03-24 09:02:04 +0100
committerSébastien Helleu <flashcode@flashtux.org>2019-03-24 09:38:43 +0100
commit2612adf8993acf3925f636dd415921c4ff06727f (patch)
tree3fe7b92d60c759a7d8c542c40f1c9ce32913f113 /src/plugins/python/CMakeLists.txt
parent47c4329404e0b79731bdaff6ddd57c729bebf76b (diff)
downloadweechat-2612adf8993acf3925f636dd415921c4ff06727f.zip
core: add CMake option "ENABLE_CODE_COVERAGE" to compile with code coverage options
This option is OFF by default and should be enabled only for tests, to measure test coverage.
Diffstat (limited to 'src/plugins/python/CMakeLists.txt')
-rw-r--r--src/plugins/python/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/python/CMakeLists.txt b/src/plugins/python/CMakeLists.txt
index 63ff4ec24..a6ca8d2b5 100644
--- a/src/plugins/python/CMakeLists.txt
+++ b/src/plugins/python/CMakeLists.txt
@@ -25,7 +25,7 @@ set_target_properties(python PROPERTIES PREFIX "")
if(PYTHON_FOUND)
include_directories(${PYTHON_INCLUDE_PATH})
set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${PYTHON_LFLAGS}")
- target_link_libraries(python ${PYTHON_LIBRARY} weechat_plugins_scripts)
+ target_link_libraries(python ${PYTHON_LIBRARY} weechat_plugins_scripts coverage_config)
endif()
install(TARGETS python LIBRARY DESTINATION ${LIBDIR}/plugins)