summaryrefslogtreecommitdiff
path: root/src/plugins/perl/CMakeLists.txt
diff options
context:
space:
mode:
authorRyan Farley <ryan.farley@gmx.com>2019-04-25 16:53:55 -0500
committerRyan Farley <ryan.farley@gmx.com>2019-04-25 16:53:55 -0500
commit8df3ad3d2613cb0dd3f034c3f1767d3f7eba056b (patch)
tree2eb38ead752e9b44c61f9083bade0a085302c0d2 /src/plugins/perl/CMakeLists.txt
parent38535686f841c107cb95ff618f7b152af98a8ff4 (diff)
downloadweechat-8df3ad3d2613cb0dd3f034c3f1767d3f7eba056b.zip
cmake: allow custom libdir (fix #1341)
Allows for custom LIBDIR to specified with cmake builds. WEECHAT_LIBDIR is used for a custom Weechat directory, or set from LIBDIR (as LIBDIR used to be set).
Diffstat (limited to 'src/plugins/perl/CMakeLists.txt')
-rw-r--r--src/plugins/perl/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/perl/CMakeLists.txt b/src/plugins/perl/CMakeLists.txt
index 234f3e70c..78d8569c5 100644
--- a/src/plugins/perl/CMakeLists.txt
+++ b/src/plugins/perl/CMakeLists.txt
@@ -43,4 +43,4 @@ if(PERL_FOUND)
endif()
endif()
-install(TARGETS perl LIBRARY DESTINATION ${LIBDIR}/plugins)
+install(TARGETS perl LIBRARY DESTINATION ${WEECHAT_LIBDIR}/plugins)