summaryrefslogtreecommitdiff
path: root/src/plugins/perl/CMakeLists.txt
diff options
context:
space:
mode:
authorSébastien Helleu <flashcode@flashtux.org>2019-03-24 09:02:04 +0100
committerSébastien Helleu <flashcode@flashtux.org>2019-03-24 09:38:43 +0100
commit2612adf8993acf3925f636dd415921c4ff06727f (patch)
tree3fe7b92d60c759a7d8c542c40f1c9ce32913f113 /src/plugins/perl/CMakeLists.txt
parent47c4329404e0b79731bdaff6ddd57c729bebf76b (diff)
downloadweechat-2612adf8993acf3925f636dd415921c4ff06727f.zip
core: add CMake option "ENABLE_CODE_COVERAGE" to compile with code coverage options
This option is OFF by default and should be enabled only for tests, to measure test coverage.
Diffstat (limited to 'src/plugins/perl/CMakeLists.txt')
-rw-r--r--src/plugins/perl/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/perl/CMakeLists.txt b/src/plugins/perl/CMakeLists.txt
index 1d9a22a6b..234f3e70c 100644
--- a/src/plugins/perl/CMakeLists.txt
+++ b/src/plugins/perl/CMakeLists.txt
@@ -36,10 +36,10 @@ if(PERL_FOUND)
string(REPLACE "${PERL_DYNALOADER}" "" PERL_LFLAGS "${PERL_LFLAGS}")
set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${PERL_LFLAGS}")
execute_process(COMMAND ${CMAKE_COMMAND} -E copy ${PERL_DYNALOADER} ${CMAKE_CURRENT_BINARY_DIR}/libDynaLoader.a)
- target_link_libraries(perl ${PERL_LIBRARY} weechat_plugins_scripts ${CMAKE_CURRENT_BINARY_DIR}/libDynaLoader.a)
+ target_link_libraries(perl ${PERL_LIBRARY} weechat_plugins_scripts ${CMAKE_CURRENT_BINARY_DIR}/libDynaLoader.a coverage_config)
else()
set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} ${PERL_LFLAGS}")
- target_link_libraries(perl ${PERL_LIBRARY} weechat_plugins_scripts)
+ target_link_libraries(perl ${PERL_LIBRARY} weechat_plugins_scripts coverage_config)
endif()
endif()